IEC template user guide

Structuring and formatting IEC publications in Microsoft® Word with iecstd_v7.3.dotm
Release notes (version 7.3) – June 2023

The major changes in this version are:

- The forewords for PASs and Fast-Track documents have been updated.
- Video tutorials have been added to a digital version of the guide, available at Writing and formatting | IEC.
- The digital signature has been renewed and timestamped – the signature will remain valid even if it has expired.

Release notes (version 7.2) – April 2023

The major changes in this version are:

- Forewords have been updated to reflect the new patent policy; point 9 of the Foreword has been entirely redrafted.
- Instructions for boilerplate text relating to the use of patents has been deleted in the Introduction of the document outline.
- The buttons to insert the boilerplate text relating to the patents have been removed from the ribbon.

Release notes (version 7.1) – April 2022

The major changes in this version are:

- The Auto cross-reference tool has been updated to take into account non-breaking spaces; either ordinary or non-breaking spaces can now be used in plain text in the element to be cross-reference (e.g. "Table\[non-breaking space\]5" will now insert a cross-reference to Table 5 and not return an error).
- Minor updates to a few styles.
- User-friendly error messages now appear instead of the default VBA error codes for some common errors.

Release notes (version 7) – May 2021

The major changes in this version are:

- The macros are digitally signed to ensure greater security for users.
- Improved tools for numbering of figures, tables, and equations in annexes – the letter of the annex is now added automatically.
- Addition of options to precede the numbering of figures, tables, and equations with the clause number, as set out in the ISO/IEC Directives, Part 2:2021.
- Tools to reset heading styles and restore level 1 numbering.
- The Auto cross-reference tool now works with equation numbers and "Tableau" in French.
- Several minor corrections, notably to hyperlinks in the forewords.
CONTENTS

1 Introduction .......................................................................................................................... 4
  1.1 The IEC template ........................................................................................................... 4
  1.2 New features in version 7 ............................................................................................. 4
  1.3 Drafting IEC publications – additional information .................................................... 4
  1.4 Copyright and terms of use of the IEC template ......................................................... 4
    1.4.1 Terms and conditions of use ................................................................................. 4
    1.4.2 Copyright statement ................................................................................................. 5
    1.4.3 Disclaimer ................................................................................................................ 5

2 The IEC template, version 7 ............................................................................................... 5
  2.1 What are the functions of the IEC template? ................................................................. 5
    2.1.1 Structure ................................................................................................................... 5
    2.1.2 Formatting ................................................................................................................ 5
    2.1.3 Automation ............................................................................................................... 5
  2.2 Technical requirements ................................................................................................. 6
  2.3 Support .......................................................................................................................... 6

3 Setting up your working environment .............................................................................. 6
  3.1 Downloading and saving the IEC template ................................................................. 6
  3.2 Settings for equations ................................................................................................. 7

4 Setting up your document ................................................................................................ 7
  4.1 Options .......................................................................................................................... 8
  4.2 Create new document from scratch ............................................................................ 8
  4.3 Attach template to existing document ......................................................................... 8
  4.4 Page setup ...................................................................................................................... 10

5 Overall outline of a document ........................................................................................... 10

6 Using the IEC tools tab ................................................................................................. 10
  6.1 General ........................................................................................................................ 10
  6.2 Button groups .............................................................................................................. 11
    6.2.1 Apply styles ............................................................................................................. 11
    6.2.2 Insert elements ....................................................................................................... 13
    6.2.3 Insert boilerplate text ........................................................................................... 16
    6.2.4 Document setup ..................................................................................................... 17
    6.2.5 French content ....................................................................................................... 17
  6.3 Terminology mask ......................................................................................................... 18
  6.4 Numbered elements in annexes ................................................................................ 20
    6.4.1 Equations ................................................................................................................. 20
    6.4.2 Figures .................................................................................................................... 20
    6.4.3 Tables ...................................................................................................................... 20
  6.5 Updating numbering ..................................................................................................... 20
  6.6 Cross-references ......................................................................................................... 21

Annex A Troubleshooting ................................................................................................... 23
  A.1 Buttons in IEC tools tab not responding/displaying error messages ....................... 23
  A.2 The IEC template is not shown under My templates ................................................. 24
  A.3 Styles behave erratically ............................................................................................. 24
  A.4 Error 5941: Requested member of the collection does not exist ....................... 25
  A.5 Numbered lists are incorrectly numbered after attaching the new template ........ 25
  A.6 MathType does not work ......................................................................................... 25
Figure 1 – Hidden items checkbox in file explorer ........................................ 6
Figure 2 – Unblock file .................................................................................. 7
Figure 3 – Add Developer tab to ribbon .......................................................... 9
Figure 4 – Select template ............................................................................ 9
Figure 5 – Attach template ........................................................................... 9
Figure 6 – Document margins ..................................................................... 10
Figure 7 – Position of IEC tools tab ............................................................... 10
Figure 8 – Apply styles group ..................................................................... 11
Figure 9 – Insert elements .......................................................................... 13
Figure 10 – Adding additional footnote references ...................................... 16
Figure 11 – Insert boilerplate text group ...................................................... 16
Figure 12 – Document setup group ............................................................... 17
Figure 13 – Terminology mask .................................................................... 19
Figure 14 – Field shading ........................................................................... 21
Figure 15 – Inserting a cross-reference to a heading .................................... 22
Figure A.1 – Macro settings ....................................................................... 23
Figure A.2 – Enable macros ......................................................................... 23
Figure A.3 – View digital signature ............................................................... 23
Figure A.4 – Digital signature .................................................................... 24
Figure A.5 – Adding an alias to Heading 1 .................................................... 26
Figure B.1 – Draft view ................................................................................ 28
Figure B.2 – Draft view styles column ........................................................... 29
Figure B.3 – Styles in Introduction ................................................................ 29
Figure B.4 – Styles of the main title ............................................................... 29
Figure B.5 – Styles used in main text ............................................................. 30
Figure B.6 – Styles in Clause 2 ..................................................................... 30
Figure B.7 – Styles used in Clause 3 .............................................................. 31
Figure B.8 – Styles used in figures ................................................................. 32
Figure B.9 – Subfigures .............................................................................. 32
Figure B.10 – Correct table alignment .......................................................... 33
Figure B.11 – Repeating header rows ........................................................... 33

A.7 Heading numbers have disappeared ...................................................... 25
A.8 Error in Clause number of table and figure numbers ........................... 25
A.9 Problems in the table of contents ......................................................... 27
Annex B IEC styles .................................................................................... 28
B.1 Styles in body of document ................................................................. 28
B.2 Styles in Normative references clause (Clause 2) ................................. 30
B.3 Styles in Terms and definitions clause (Clause 3) ................................. 30
B.4 Styles in figures .................................................................................... 31
B.5 Figures with subfigures ...................................................................... 32
B.6 Styles in tables ..................................................................................... 32
B.7 Styles in the Bibliography .................................................................... 33
B.8 Heading styles in amendments ............................................................. 34
B.9 Style shortcuts ...................................................................................... 34
Figure B.12 – Styles used in a numbered bibliography .................................................. 34
Figure B.13 – Amendment headings ............................................................................. 34
Table 1 – Terminology mask fields ............................................................................. 20
Table B.1 – Keyboard shortcuts ................................................................................... 35
1 Introduction

1.1 The IEC template

The IEC template for MS Word (currently iecstd_v7.3.dotm) provides the basis for the structuring and formatting of IEC publications. It is designed to facilitate the work of authors and needs to be attached to all working documents.

The IEC template contains styles for the various elements of an IEC publication (normal text, headings, lists, etc.). It also contains autotexts (forewords and other boilerplate texts) and facilitates the insertion of terminology, table and figure titles, and other elements into a document.

The main task of IEC experts is to provide the content and its structure.

The IEC template can help you create the structure in your document. This provides essential information about the hierarchy of the content. Apply the IEC styles to define the identity of the various elements in your document and the relationship between them.

The IEC template can also help you format your content. However, we do not expect a perfectly formatted document. If you are not sure how to handle a formatting issue which is not essential to the structure of your document, do NOT try to find a workaround — more often than not, this complicates things at later stages. The IEC Layout team will take care of your document at the CDV stage, if necessary.

In case of any difficulty, or if you need advice, contact us at layout@iec.ch so we can help you find a solution in line with the IEC publication requirements.

1.2 New features in version 7

The most important update in this version is that the macros are digitally signed. The digital signature guarantees the origin of the macros, greatly increasing security and allowing more users to make full use of the available tools.

The IEC tools tab, which automatically appears in Word’s ribbon when the IEC template file is attached to a document, contains all the features available in previous versions, with the addition of

- improved tools for numbering of figures, tables, and equations in annexes – the letter of the annex is now added automatically,
- the option to precede the numbering of figures, tables, and equations with the clause number, as set out in the ISO/IEC Directives, Part 2:2021,
- the "Auto cross-reference" tool now works with equations and French labels, and
- the addition of two buttons to reset heading styles and the numbering of level 1 headings.

1.3 Drafting IEC publications – additional information

The IEC template helps authors to elaborate IEC publications in conformity with the ISO/IEC Directives, Part 2. Download the Directives and IEC Supplement at:
https://www.iec.ch/members_experts/refdocs/

Additional information on the drafting of IEC publications is available on the IEC website:
https://www.iec.ch/standards-development/drafting-iec-publications

1.4 Copyright and terms of use of the IEC template

1.4.1 Terms and conditions of use

Your use, distribution, or installation of the IEC template indicates your acceptance of the copyright and terms of use outlined hereafter. If you do not agree to any of the terms of use, then do not download, install, distribute, or use the IEC template.
1.4.2 Copyright statement

© 2023 IEC, Geneva, Switzerland. All rights reserved. The tailored content of the MS Word template iecstd_v7.3.dotm is copyright IEC to aid in the preparation of IEC publications.

The IEC template may be used free of charge for the development of IEC and ISO/IEC publications. Use for any other purpose is forbidden unless permission has been received in writing from IEC. Requests should be sent to layout@iec.ch.

MS Windows and Word are registered trademarks of Microsoft Corporation.

1.4.3 Disclaimer

Although the IEC template has undergone rigorous testing, there is no guarantee that all its elements are error-free. They are supplied "as-is" without warranty of any kind, either expressed or implied. No liability is assumed by the IEC for incidental or consequential damage resulting from its use.

The IEC template was developed and tested using MS Office 365 under the MS Windows 10 operating system. There is no guarantee that it will function on all platforms and all types of software, in all language versions (shortcut keys, in particular). Should these it not function on your system, the IEC is under no obligation to provide a solution.

The IEC makes no claim as to the absence of computer viruses in the delivered files or their support. As a result, the IEC recommends that all files and their support be checked by the end user for viruses.

2 The IEC template, version 7

2.1 What are the functions of the IEC template?

2.1.1 Structure

By applying styles to text, you structure a document's content. A style defines the function of a block of text (e.g. is it a heading, a note, an example, a term...?) and the hierarchy of the various elements (e.g. is it a clause or a subclause?).

2.1.2 Formatting

Styles help format text. For example, a clause heading is defined as Arial 11 + bold, a subclause as Arial 10 + bold, subscript text as Arial 8 + lowered by 3 points. Instead of defining all the different parameters individually for each element, you can apply a style with one click.

2.1.3 Automation

Tasks are automated in different ways:

- Applying heading styles to clauses and subclauses numbers them automatically, and ensures they appear in the table of contents.
- Inserting the autotexts from the IEC template prevents authors from having to type or copy the text manually.
- The Terminology mask (see 6.3) formats terminological entries when inserting them in the document.
- By clicking on the respective button in the IEC tools tab, authors can create
  - new annexes;
  - automatically numbered table and figure titles;
  - automatically numbered equations;
  - automatic line numbering;
  - a table of contents;
  - landscape pages.
2.2 Technical requirements
The IEC template should work in all versions of MS Word since 2007.

The IEC template is primarily intended to work in an MS Windows environment. It may work with other operating systems, but we cannot guarantee this, nor provide support in such cases.

2.3 Support
If you need help with the use of the IEC template and for comments or questions concerning this guide or the IEC template, contact us at layout@iec.ch.

3 Setting up your working environment

3.1 Downloading and saving the IEC template
Download the IEC template iecstd_v7.3.dotm at http://www.iec.ch/standardsdev/resources/draftingpublications/layout_formatting/IEC_template/iec_template.htm and save it in Word’s Templates folder on your computer.

In Windows 10, the folder is located here:
C:\Users\[user name]\AppData\Roaming\Microsoft\Templates

If you would like the IEC template to load automatically when you start Word (this will open the IEC template in all Word documents on your computer):
C:\Users\[user name]\AppData\Roaming\Microsoft\Word\STARTUP

In order to view the contents of these folders, you may need to check the Hidden items box in the View tab in the file explorer (see Figure 1):

![Figure 1 – Hidden items checkbox in file explorer](image)

IMPORTANT!

A security measure introduced mid-2022 by Microsoft systematically blocks macros in files downloaded from the Internet. To enable the macros, locate the template file in the folder in which it is saved, right-click on the template file, and click on Properties. Tick the “Unblock” checkbox and click on OK, as shown in Figure 3.

---

© IEC 2023
3.2 **Settings for equations**

MathType is the recommended software for composing equations in Word documents, because it produces consistent and repeatable results that are fit for publishing, even with complex expressions. Otherwise, you can use Word’s built-in equation editor; equations created in this manner will be converted to MathType format when you submit your drafts to the IEC Secretariat.

See the following page for more information, including the settings for MathType:
https://www.iec.ch/standardsdev/resources/draftingpublications/writing_formatting/IEC_rules/equations.htm

4 **Setting up your document**
4.1 Options
To benefit from the features in the IEC template, it needs to be attached to your working document. There are two options to do this:

1) Creating a new document from scratch, based on the IEC template. This allows you to benefit from the model structure the IEC template provides.

or

2) Attaching the IEC template to an existing document

4.2 Create new document from scratch
Double-click on iecstd_v7.3.dotm to open it, then go to File > Save As, and save as a docx file.

If you do not subsequently move iecstd_v7.3.dotm to a different folder, the IEC template should remain attached next time you open the file. Otherwise, you will need to attach the IEC template manually (see 4.3).

4.3 Attach template to existing document

1) Ensure that you have downloaded and saved the IEC template – do not open it! – to the Templates folder; see 3.1.

2) Open the Word file to which the IEC template needs to be attached.

3) In Word, make the Developer tab visible if not already the case (it is hidden by default). Go to File > Options > Customize Ribbon, and check the Developer box (see Figure 3). Then click OK.

4) Go to the Developer tab, click on Document Template (see Figure 4).

5) Click Attach..., select the IEC template (iecstd_v7.3.dotm) and click Open. If this is the first time that you are attaching the IEC template, check the option Automatically update document styles (see Figure 5), and click OK.

6) The IEC tools tab will appear, and the styles will be updated.

7) Go back to Document Template and untick "Automatically update document styles" in step 5), and click OK. This is necessary to ensure that the styles are not updated each time you open the file; this can cause problems if you have had to tweak some text for presentation purposes (e.g. to fit content in one line/cell of a table) or if styles have been deliberately modified to allow for a different numbering scheme.
Figure 3 – Add Developer tab to ribbon

Figure 4 – Select template

Figure 5 – Attach template
4.4 Page setup

When you attach the IEC template to an existing document, the document margins are not set automatically. The margins have to be set up with the values shown in Figure 6 (Layout tab > Margins > Custom margins...):

![Image of Page Setup dialog box](image)

**Figure 6 – Document margins**

5 Overall outline of a document

Refer to the ISO/IEC Directives, Part 2, for more information about content that shall appear in IEC documents and the order in which it shall appear. The Directives are available online at the following page: [https://www.iec.ch/standards-development/isoiec-directives-part-2](https://www.iec.ch/standards-development/isoiec-directives-part-2)

6 Using the IEC tools tab

6.1 General

When the IEC template is correctly attached to a document, the IEC tools tab appears in the ribbon, in the first position starting from the right (assuming there are no other personalised tabs); see Figure 7.

![Image of IEC tools tab](image)

**Figure 7 – Position of IEC tools tab**
Subclauses 6.2.1 to 6.2.5 explain the features of each group within the tab, from left to right. Hovering the mouse over the buttons in the tab also provides some basic information.

6.2 Button groups
6.2.1 Apply styles
6.2.1.1 Applying the IEC styles

Using the IEC styles in the *IEC tools* tab ensures consistent formatting of all IEC publications.

Only use the styles that are accessible through the *Apply styles* group of the *IEC tools* tab (shown in Figure 8). Select the text to format and click on the appropriate style. Do not use the *Home* tab to format text.

**Figure 8 – Apply styles group**

Removes all formatting in the selected text; resets to Word’s built-in *Normal* style. A style from the IEC template needs to be applied after removing formatting.

---

Drop-down menu. Styles text as a heading from levels 1 to 6, the maximum allowed in IEC documents. Do not use Word’s built-in levels 7 to 9.

Includes amendment headings level 1 (for use with clause headings) and level 2 (for use with subclause headings, levels 2 to 6). See Clause B.8 for more information.

Reset heading styles: if the heading styles have lost their numbers or spacing and positioning, click on this button. Do not use on documents with discontinuous numbering because all the numbering will be reset to sequential numbering.

Reset heading 1 numbering: it has been known for some documents that were authored using older templates to lose their level 1 numbering when the newer .dotm templates are applied. Click here to restore level 1 numbering.

Heading numbering usually starts at 1. If you need to start the numbering at a number other than 1, right click on the number of the heading and click *Set numbering value*.

---

The style to be applied to ordinary text.

Use this style to format superscripts. Do not use the superscript button in the *Home* tab.

Use this style to format superscripts in tables, notes and examples.
Apply this style to notes.

Use this style to format subscripts. Do not use the subscript button in the Home tab.

Use this style to format subscripts in tables, notes and examples.

Apply this style to examples.

Drop-down menu providing the option to format symbols representing variable quantities in the main text and in subscripts and superscripts.

Use the small variants in tables, notes, and examples.

Opens a pane that contains all the styles that can be used. For more details on the styles, see Annex B.

Formats alphabetical lists starting with a) (preferred; 5 levels possible), or numbered lists starting with 1) (3 levels possible).

Lists start with the next available letter or number. To restart the list at a) or 1), right click on the first letter or number of the list and click Restart at a or Restart at 1.

The button Reset list numbers resets the numbering of lists. When the new template is attached to a document, it can cause the numbering of lists to be modified: the numbering can sometimes continue on from previous lists in the document, and the restart markers (i.e. a) or 1)) can be ignored. This results in numbering such as a), j), k) (the previous list in the document ended with item i)), instead of a), b), c). This button should reset the lists to their correct, original, numbering.

Formats bullet point or dashed lists, both with 5 levels possible.

Indents a paragraph to match the level of the preceding list item.

Formats the header rows of tables.

Formats the content of a table cell; aligns the content to the left of the cell.

Formats the content of a table cell; centres the content of the cell.
Drop-down menu. Styles text as an annex heading (Annex heading 1 to Annex heading 5) in the annex, the maximum allowed in IEC documents. Do not add further subdivisions.

6.2.1.2 Using shortcuts to apply styles

Nearly all styles can be applied using keyboard shortcuts. For some recurring styles, it can be useful to memorize their shortcuts. In the IEC tools tab, move the mouse over the style buttons to view their shortcuts.

A list of shortcuts is also given in Annex B.

How many of the shortcuts work will depend on the language version of Word, and the practicality of some will depend on your keyboard layout. The shortcuts in the IEC template are intended for use in the English language version. If you wish, you can set your version of Word to English in File > Options > Language.

6.2.2 Insert elements

The Insert elements group (third position from left) is shown in Figure 9.

![Figure 9 – Insert elements](image)

Insertion of terms and definitions is facilitated by an input mask. Click on Insert term; the terminology mask shown in Figure 13 appears. See Table 1 for notes on each of the fields.

Fill in the fields to create a terminological entry in accordance with the ISO/IEC Directives, available on the following page: https://www.iec.ch/standards-development/isoiec-directives-part-2 > Clause 16: Terms and definitions

See also 6.3.
To insert a numbered equation, click **Insert equation > Standalone equation**. Four options are available:

- **X**: sequential numbering (1, 2, 3, ...) in the main text of the document;
- **X-X**: sequential numbering (reset to 1 at the start of each clause) preceded by the number of the clause in which the equation appears (see ISO/IEC Directives, Part 2:2021, 27.3 for more information);
- **A.1**: use to number the first equation in an annex;
- **A.X**: use to number subsequent equations in an annex.

A borderless table with three columns is inserted. A placeholder for the equation is present in the central cell. The right-hand cell contains the equation number, which is automatically incremented. Do not put anything in the left-hand cell, and do not modify the widths of the table or the columns.

A placeholder list is also inserted for the description of symbols used in the equation (in the style List, available via the **Other styles** button in the **Apply styles** group). Delete this list if it is not needed.

To insert an unnumbered inline equation within a sentence or a list, click **Inline equation**.

A new annex heading bearing the next sequentially available letter is inserted on a new page.

To insert a sequentially numbered figure title in the main text of a document, click on **Figure > Title Figure X**. A placeholder for the figure, with the correct style applied, and figure title comprising the next available number is inserted. This is the preferred numbering format.

**Title Figure X-X** inserts a figure title with a sequential number (reset to 1 at the start of each clause) preceded by the clause number in which the figure appears. More information related to this numbering format can be found in the ISO/IEC Directives, Part 2:2021, 28.3.

**Title Figure A.1** is used for numbering the first figure of an annex. **Title Figure A.X** is used for numbering subsequent figures of an annex.

For convenience, Word’s built-in picture insertion tool has been added to the drop-down **Figure** menu (identical to the **Insert Picture From This Device**... menu in the **Insert** tab).
To insert a sequentially numbered table title in the main text of a document, click on Table > Title Table X.

**Title Table X-X** inserts a table title with a sequential number (reset to 1 at the start of each clause) preceded by the clause number in which the table appears. More information related to this numbering format can be found in the ISO/IEC Directives, Part 2:2021, 29.3.

**Title Table A.1** is used for numbering the first table of an annex. **Title Table A.X** is used for numbering subsequent tables of an annex.

For convenience, Word's built-in table insertion tool has been added to the bottom of the drop-down Table menu (identical to the Table menu in the Insert tab). Use this tool to insert the table below the table title.

The styles used in tables are presented in Clause B.6. This clause also contains important information about alignment of content in tables.

---

The **Insert landscape pages** button inserts two landscape pages (horizontal page layout), followed by a portrait page (normal, vertical page layout), with the correct section breaks, headers and page margins.

If you insert landscape pages, the headers in each section will need to be checked because the section breaks that are inserted for the landscape pages reset the headers in the preceding sections. This will be corrected by the Secretariat in your document.

To add landscape pages, insert a page break on the last landscape page – there is no need to click the Landscape page button again.

To remove a landscape page, delete the page break.

Top tip: click on ▼ in the Home tab to see page breaks and other hidden formatting symbols.

---

Converting static (manually typed) cross-references to dynamic cross-references. Works with headings (clauses and subclauses), term numbers, tables, figures, annexes, and equations. Does not work with list items (but does work with numbered bibliographic entries). Will not work in documents with discontinuous numbering (e.g. amendments).

Select the cross-reference, and click on this button. If the cross-reference is found, a dynamic reference will be inserted. If it is not found, the text will be highlighted in red.

For this tool to work properly, tables and figures have to be numbered as described in the descriptions of the "Figure" and "Table" buttons above.

To create a cross-reference to an equation, the parentheses have to be selected. For example, to create a cross-reference to Equation (1), select "(1)"; selecting "1" will create a cross-reference to Clause 1 (the Scope).

Shortcut: Alt + Y
Word’s built-in cross-references tool allows dynamic cross-references to be inserted, which ensures that references to the various elements of the document will remain correct if numbering is modified or if tables and figures are inserted or removed.

See 6.6 for more details.

Inserts a footnote (Word’s built-in tool).

To add a second reference to an existing footnote, place the cursor where the reference is to be inserted, click on the Cross-references button, select Footnote as the Reference type in the drop-down list, select Footnote number (formatted) under Insert reference to; and click Insert (see Figure 10).

![Figure 10 – Adding additional footnote references](image)

6.2.3 Insert boilerplate text

The Insert boilerplate text group is in first position starting from the left (see Figure 11).

![Figure 11 – Insert boilerplate text group](image)
At the top of a new page, select the document type from this drop-down menu to automatically insert the correct foreword.

Text in red needs to be modified according to the content of the document.

Drop-down list with the two possible boilerplate options for Clause 2, the normative references clause. Select the option that applies.

Drop-down list with the four possible boilerplate options; select the one that applies.

6.2.4 Document setup

The Document setup group (second position from left) is shown in Figure 12.

**Figure 12 – Document setup group**

- **Add line numbers**
- **Remove line numbers**
- **Insert table of contents**

Enables and disables automatic line numbering for CD and CDV documents.

Place the cursor at the top of the document and click on Insert table of contents to insert a table of contents that complies with IEC requirements, namely three levels of clauses/subclauses, annex titles, annex headings 1 and 2, and figure and table titles.

**IMPORTANT:** use the styles provided in the template (i.e. described in this guide) for headings, figure titles and table titles to ensure that the table of contents is correct and complete.

To update the table of contents, right-click anywhere in the contents it and click on Update field; else left-click anywhere in the contents and press F9. You can either update only the page numbers or the entire table (i.e. titles and page numbers).

The table of contents comprises three separate tables: one for clause and subclause headings, one for figures and one for tables. Therefore, remember to update each table. Alternatively, you could select all three tables before updating (i.e. pressing F9).

6.2.5 French content

The French texts button is a drop-down menu containing translations of the forewords and boilerplate texts in the Insert boilerplate text group.

It also contains menus for inserting figures (Insérer une figure), tables (Insérer un tableau) and annexes (Insérer une annexe), as well as the styles for annex headings in French. Different styles are required to English versions to allow for the “e” at the end of “Annexe” without the need for a separate template for French versions. A button at the bottom of the
menu, Convert to new annex headings, converts styles in previous editions to the new annex styles for French.

If drafting in French, it is necessary to use the French figure and table insertion buttons in order to ensure that the numbering of the figures and tables is reset correctly in the annexes.

The Auto cross-reference tool described in 6.2.2 now works with the French label "Tableau"; i.e. creating a cross-reference to "Tableau 1" will now work correctly.

6.3 Terminology mask

Insertion of terms and definitions is facilitated by an input mask. Click on Insert term in the Insert elements group; the terminology mask shown in Figure 13 appears. See Table 1 for notes on each of the fields.

Fill in the fields to create a terminological entry in accordance with the ISO/IEC Directives, available on the following page:
https://www.iec.ch/standards-development/ Clause 16: Terms and definitions
This window helps you create a terminological entry, inserting the elements in the correct order and with the correct styles applied. However, it does not support figures, equations, special symbols and special formatting. If necessary, figures, equations, symbols and special formatting can be added later.

**Figure 13 – Terminology mask**
Table 1 – Terminology mask fields

<table>
<thead>
<tr>
<th>Insert term at 3rd level</th>
<th>Check the box if the Terms and definitions clause contains subdivisions (e.g. 3.1 Terms and definitions, 3.2 Abbreviated terms). The term number will be a 3rd level numbered item, for example 3.1.1 instead of 3.1.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Term</td>
<td>MANDATORY FIELD</td>
</tr>
<tr>
<td></td>
<td>To add another preferred term or a deprecated or admitted term, click on the +. Remember to specify for each term whether it is preferred, admitted, or deprecated by selecting the appropriate value in the drop-down list. The first term is automatically set to Preferred.</td>
</tr>
<tr>
<td>Symbol</td>
<td>Special characters cannot be used with this mask; insert them directly in the document.</td>
</tr>
<tr>
<td>Definition</td>
<td>MANDATORY FIELD</td>
</tr>
<tr>
<td></td>
<td>Shall comprise a single sentence. Do not begin the definition with &quot;a&quot; or &quot;the&quot;; do not end it with a full stop.</td>
</tr>
<tr>
<td>Example</td>
<td>Click the + to insert more than one example. The field will be omitted if left blank.</td>
</tr>
<tr>
<td>Note to entry</td>
<td>Click the + to insert more than one note to entry. The field will be omitted if left blank.</td>
</tr>
<tr>
<td>Source</td>
<td>Remember to state how the new entry has been modified compared to the source. The field will be omitted if left blank.</td>
</tr>
<tr>
<td>Insert</td>
<td>Inserts the contents of the mask into the document.</td>
</tr>
<tr>
<td>Reset</td>
<td>Clears all the content in all the fields.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the mask; does not insert entry into document upon closing.</td>
</tr>
</tbody>
</table>

In the event of a problem with the mask, or if the term contains symbols or non-verbal content, terms and definitions can be typed directly in the document and the styles for each element of the terminological entry can be applied manually. The styles to be used are presented in Annex B.

6.4 Numbered elements in annexes

6.4.1 Equations

In annexes, equations are numbered according to the pattern A.X, where A is the letter of the annex, and X is the sequential number. Numbering shall restart at 1 at the start of each annex; this is done by clicking on Standalone equation A.1 in the Insert equation menu in the Insert elements group; the letter of the annex will update automatically.

Use Standalone equation A.X for subsequent equations.

6.4.2 Figures

In annexes, figures are numbered according to the pattern A.X, where A is the letter of the annex, and X is the sequential number. Numbering shall restart at 1 at the start of each annex; this is done by clicking on Title Figure A.1 in the Figure menu of the Insert elements group. A figure title bearing the number A.1 is inserted, along with a placeholder for the figure; the letter of the annex will update automatically.

For subsequent figures in an annex, use Title Figure A.X.

6.4.3 Tables

Just like figures, tables are numbered according to the pattern A.X, where A is the letter of the annex, and X is the sequential number. Numbering shall restart at 1 at the start of each annex; this is done by clicking on Title Table A.1 in the Table menu of the Insert elements group. A table title bearing the number A.1 is inserted; the letter of the annex will update automatically.

For subsequent tables in an annex, use Title Table A.X.

6.5 Updating numbering

If a figure is inserted before the last existing figure in the document, the numbering of the figures will need to be updated. Until this is done, the inserted figure will bear the same number as the next figure.
There are two ways to do this:

a) either select the affected fields and press F9 (or right-click immediately to the left of the field and click Update Field); or

b) select the whole document (Ctrl + A), and press F9.

Bear in mind that option b) will update every field in the document. It is not advisable to do this until the various elements of the document have been dynamically cross-referenced; see 6.6.

6.6 Cross-references

If you know the number of the clause, subclause, annex, table, figure, equation, or bibliographic entry that you want to refer to, it is recommended to use the Auto cross-reference tool (see 6.2.2).

Top tip: it is useful to enable field shading in Word’s options. This will apply grey shading to all fields in the document, including dynamic cross-references. This makes it easy to immediately see where dynamic cross-references have been created. To enable field shading, go to File > Options > Advanced, and set Field shading to Always. See Figure 14.

To insert a dynamic cross-reference, click on Cross-references in the Insert elements group and select the type of element to refer to in the Reference type drop-down list. Figure 15 shows Numbered items (headings) being selected as the reference type.

When referring to headings and bibliographic entries (Numbered item in the Reference type drop-down list), select Paragraph number in the Insert reference to drop-down list.

When referring to tables and figures, select Only label and number in the Insert reference to drop-down list.

When referring to equations, select Entire caption in the Insert reference to drop-down list.

When referring to footnotes, select Footnote number in the Insert reference to drop-down list.

Ensure that the Insert as hyperlink box is always ticked. Figure 15 shows the correct setup for inserting a cross-reference to a heading.
Figure 15 – Inserting a cross-reference to a heading
Annex A

Troubleshooting

A.1 Buttons in IEC tools tab not responding/displaying error messages

The settings in Word are disabling the macros. To enable the macros, go to File > Options > Trust Center > Trust Center settings > Macro settings. Select Disable all macros except digitally signed macros, and click OK. See Figure A.1.

![Figure A.1 – Macro settings](image)

When you open the file, you will be prompted to enable the macros. Click Enable to use all the features of the IEC template (see Figure A.2).

![Figure A.2 – Enable macros](image)

Or you can view the IEC's digital signature by clicking on "Click for more details". Then click on Enable Content > Advanced Options (see Figure A.4).

![Figure A.3 – View digital signature](image)
Figure A.4 shows the box that will appear. You can choose to accept to trust all documents from the IEC to prevent the security warning from appearing every time you open your IEC files.

![Microsoft Office Security Options](image)

**Figure A.4 – Digital signature**

If the macros are enabled, but you are still getting an error message, it could be that another add-in on your computer is causing the problem, particularly if you updated to a new version of Word and carried over settings from the previous version. As an example, see the following discussion on Microsoft's website: https://answers.microsoft.com/en-us/msoffice/forum/all/word-template-macro-not-working/4cd54039-ae84-49cd-a08f-9aa7604730cb

### A.2 The IEC template is not shown under *My templates*

If `iecstd_v7.3.dotm` is not in your *Templates* folder, save it there by following the instructions in 3.1.

### A.3 Styles behave erratically

When styles start to behave erratically, repeat the steps to attach the IEC template (see 4.3) and check *Automatically update document styles*. When you click on *OK*, the correct IEC formatting should come back.

If it does not, it is likely that your copy of the IEC template has become corrupted. In this case, download a fresh copy of the IEC template from the [IEC website](http://ieeeweb.iec.ch). Then save the IEC template in its appropriate place (see 3.1) and attach it to your document again, in accordance with the instructions in 4.3.
A.4 Error 5941: Requested member of the collection does not exist

Many of the buttons in the IEC tools tab rely on the corresponding styles being available in the document. This error will occur if the styles are absent. See steps 5) to 7) in 4.3 to update the styles in the document.

A.5 Numbered lists are incorrectly numbered after attaching the new template

When the new template is attached to a document, it can cause the numbering of lists to be modified: the numbering can sometimes continue on from previous lists in the document, and the restart markers (i.e. a) or 1)) are ignored. This results in numbering such as a), j), k) (the previous list in the document ended with item i)), instead of a), b), c).

Click once on the Reset list number in the Numbered lists menu (see 6.2.1) to reset the numbering of all numbered lists in the document.

A.6 MathType does not work

If attempting to run MathType leads to an error message, the problem can sometimes be solved by simply copying the file MathPage.wll (by default in C:\Program Files (x86)\MathType\MathPage\32 [or \64 for a 64-bit installation]) to Word's startup folder (Windows 10 default C:\Users\[user name]\AppData\Roaming\Microsoft\Word\STARTUP).

A.7 Heading numbers have disappeared

It is sometimes necessary to update the styles in the document a second time. Please repeat steps 5) to 7) in 4.3.

If the numbering still does not appear, use the buttons in the Headings menu to reset the numbering (see 6.2.1).

If Annex headings (e.g. Annex A, Annex B…) do not appear after a second update, place the cursor where the heading should appear and click on the ANNEX heading style, which is available via the Other styles button or in the Home tab, where it should be the first style shown in the Styles group.

A.8 Error in Clause number of table and figure numbers

If you are using the Figure X-X/Table X-X numbering formats and are updating the fields in a different language version of Word to the one in which the fields were created, you will see an error instead of the clause number:

```
Error! Use the Home tab to apply Überschrift 1 to the text that you want to appear here. -1- General schematic of a typical hydropower plant arrangement
```

The clause number (which corresponds to the first X) will be replaced with an error message if you update the fields in a version of Word that is running in a different language to the version of Word in which the numbering was inserted. This is because the clause number is based on the style Heading 1, which is a built-in style of Word whose name changes according to the language version of Word being used (e.g. Heading 1 is Titre 1 in French and Überschrift 1 in German). To correct this issue, it is necessary to add the name of the Heading 1 (or equivalent in another language) style of the other language as an alias for Heading 1 (or equivalent in another language).

To correct the numbering in this case, the alias Überschrift 1 needs to be added to the style Heading 1. This is done by navigating to Heading 1 in the styles panel in Word, and by modifying the name of Heading 1 to read "Heading 1,Überschrift 1". The steps are illustrated in Error! Reference source not found..

Once you have added the alias, updating all the fields in the document (Ctrl + A, then F9) will clear the error messages in the figure and table titles and the correct clause number will be
displayed. You can also update each field individually by navigating to each field displaying an error, clicking on it, then pressing F9 (or right-click and "Update field").

Figure A.5 – Adding an alias to Heading 1
A.9 Problems in the table of contents

Two recurring issues encountered in the creation of the table of contents (TOC) are:

a) figures appearing in the TOC (in addition to the corresponding title); and
b) “Error! Reference not found” appearing instead of a page number when the table is updated.

Case a) occurs when a figure is styled with the style "FIGURE-title", the style used for the titles of the figures, and which is used for populating the list of figures in the TOC. To remove the figure from the TOC, navigate to the figure in the document, and change the style of the paragraph in which the figure is located to a different style, preferably the style "FIGURE". Then update the TOC (see 6.2.4).

Case b) occurs when the link to the corresponding title is broken; this can happen when entire titles are modified after the cross-references have been created (the hidden bookmarks that are used to mark the locations of the titles are displaced), particularly when the document has been worked on in Track changes mode. The simplest way to fix this is to navigate to the title in the document for which the page number is not updating, and to create the title again using the tools in the Insert elements section of the IEC tools tab (see instructions in 6.2.2). Once the title has been recreated, update the TOC (see 6.2.4).
Annex B

IEC styles

B.1 Styles in body of document

Use the styles Heading 1 to Heading 6 for the headings of the document in the Annex headings menu of the Apply styles group. IEC guidelines allow for a maximum of 6 subdivisions; therefore, do not use Heading 7 to Heading 9.

If your document has a lot of discontinuous numbering, it could be simpler to use the heading styles used in amendments; these styles allow you to type the clause/subclause number. See Clause B.8.

Numbered paragraphs may be used in lieu of level 2 to level 4 headings. Use the styles Numbered PARA (level 2), Numbered PARA (level 3) and Numbered PARA (level 4) available in the Other styles button in the Apply styles group.

For ordinary text, use the style Paragraph (Alt + A).

For text in italics, use the style Emphasis (Alt + I). Do not use the italics button in the Home tab (Ctrl + I).

For bold text, use the style Strong (Alt + B). Do not use the bold button in the Home tab (Ctrl + B).

If you need to combine bold and italics, use the style Intense emphasis (Alt + M).

Emphasis, Strong, and Intense emphasis are also available via the Other styles button in the Apply styles group.

For the headings INTRODUCTION and Bibliography, use the style HEADING(nonumber). Figure B.3 shows styles applied to an Introduction. Figure B.4 shows the styles and layout of the main title. Figure B.5 shows the styles used in clauses and subclauses of the main text.

The figures in this annex show present the content in "Draft View", which is accessed in the View tab, Views group, then Draft (see Figure B.1).

![Figure B.1 – Draft view](image)

The column displaying the styles may be too small to view the style names in full. To correct this, go to File, Settings, Advanced, and set the width of the column under the Display section. A width of 5 cm is sufficient (see Figure A.5).
Word Options

General
Display
Proofing
Save
Language
Ease of Access
Advanced
Customize Ribbon
Quick Access Toolbar
Add-ins
Trust Center

**Display**

- Show this number of Recent Documents: 50
- Quickly access this number of Recent Documents: 4
- Show this number of unpinned Recent Folders: 50
- Show measurement in units of: Centimeters
- Stylearga panewidth in Draft and Outline views: 5 cm
- Show pixels for HTML features
- Show shortcut keys in ScreenTips
- Show horizontal scroll bar
- Show vertical scroll bar
- Show vertical ruler in Print Layout view
- Optimize character positioning for layout rather than readability
- Disable hardware graphics acceleration

---

**Figure B.2 – Draft view styles column**

---

**INTRODUCTION**

The purpose of this Introduction is to provide background regarding the basic guidance that prompts its preparation and how it relates to the Scope.

In the design of any electrotechnical product, the risk-of-fire and the potential hazards associated with fire need to be considered. In this respect, the objective within the design of component, circuit, and product design, as well as the choice of materials, is to reduce to acceptable levels the potential risks of fire during normal operating conditions, reasonable foreseeable abnormal use, malfunction, and/or failure. IEC Technical Committee 89 has developed IEC 60695-1-10, together with its companion, IEC 60695-1-11, to provide guidance on how this is to be accomplished.

The primary aims of IEC 60695-1-10 and IEC 60695-1-11 are to provide guidance on how:

a) to prevent ignition caused by an electrically energized component part, and
b) to confine any resulting fire within the bounds of the enclosure of the electrotechnical product in the event of ignition.

---

**Figure B.3 – Styles in Introduction**

---

**FIRE HAZARD TESTING**

**Part 2-11: Glowing/hot-wire-based test methods**

**1. Scope**

This part of IEC 60695 specifies a test method on an end product. It is intended to simulate the effects of thermal stresses produced by an electrically-heated source to

---

**Figure B.4 – Styles of the main title**
B.2 Styles in Normative references clause (Clause 2)

Use the Paragraph style for the entries; style the titles with *Emphasis*. This is illustrated in Figure B.6.

B.3 Styles in Terms and definitions clause (Clause 3)

The styles to be used in the terms and definitions clause all start with "TERM-". Here is an example of an entry using the names of the styles; Figure B.7 also illustrates correct use of the styles.

3.1 TERM-number
TERM
TERM-admitted
TERM-definition

Note 1 to entry: TERM-note
Example: TERM-example

[SOURCE: TERM-source]
When the terminology mask is used (see 6.3), these styles are applied automatically. Otherwise, they are accessible via the *Other styles* button in the *Apply styles* group.

![Figure B.7 – Styles used in Clause 3](image)

**B.4 Styles in figures**

The figure itself has the style *FIGURE*. The figure title is styled with *FIGURE-title*. These styles are applied automatically when using the *Figure* menu in the *IEC tools* tab (see 6.2.2), but are also available in the *Other styles* button in the *Apply styles* group.

Use the style *NOTE* for notes (see Figure B.8), and *TAB-FIG-footnote* for footnotes and the key to the figure. Bold type is applied to the word "Key" with the style *Strong* (Alt + B).
Figure B.8 – Styles used in figures

B.5 Figures with subfigures

If a figure contains subfigures, use a table to align the content; avoid using tabs and spaces. Figure B.9 illustrates the correct approach with a 2 × 2 table, created using Word’s built-in table tool (Insert table, available in the Table menu of the Insert elements group). The figures have the style FIGURE. The titles of the subfigures are styled with Table column heading (available in the Apply styles group). All borders should be made invisible (set to No border).

Figure B.9 – Subfigures

B.6 Styles in tables

The following example illustrates the styles used in tables:
Table 1 – TABLE-title

<table>
<thead>
<tr>
<th>TABLE-col-heading</th>
<th>TABLE-col-heading</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell aligned left, TABLE-cell&lt;sup&gt;a&lt;/sup&gt;</td>
<td>Cell aligned in the centre, TABLE-centered</td>
</tr>
</tbody>
</table>

NOTE Use the style NOTE (Alt + N)
<sup>a</sup> Use TAB-FIG-footnote for table footnotes. Use SUPERscript-small for footnote letters.

(Add a blank line after the table formatted as a NOTE to maintain correct spacing.)

If content needs to be aligned from one column to the next, ensure that the content to be aligned is in its own row with no other content. In other words, use table rows to align content, and do not use carriage returns! Figure B.10 illustrates this point.

<table>
<thead>
<tr>
<th>Weight</th>
<th>Colour</th>
<th>Owner</th>
</tr>
</thead>
<tbody>
<tr>
<td>Car</td>
<td>1 000 kg Gravity blue</td>
<td>Mickey</td>
</tr>
<tr>
<td>Tractor</td>
<td>5 000 kg Purple</td>
<td>Snoopy</td>
</tr>
<tr>
<td>Combine harvester</td>
<td>25 000 kg Brown with pink highlights</td>
<td>Tintin</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Weight</th>
<th>Car</th>
<th>Tractor</th>
<th>Combine harvester</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1 000 kg</td>
<td>5 000 kg</td>
<td>25 000 kg</td>
</tr>
<tr>
<td>Colour</td>
<td>Gravity blue</td>
<td>Purple</td>
<td>Brown with pink highlights</td>
</tr>
<tr>
<td>Owner</td>
<td>Mickey</td>
<td>Snoopy</td>
<td>Tintin</td>
</tr>
</tbody>
</table>

<sup>a</sup>) Not OK, data not aligned  
<sup>b</sup>) OK; invisible borders are permitted

Figure B.10 – Correct table alignment

If a table is spread over two or more pages, select the header rows to be repeated on each page and click Repeat Header Rows on the table Layout tab that appears at the right-hand end of Word's ribbon when a table is selected (see Figure B.11). This will ensure that, if the table stretches across several pages, the header rows are displayed on top of each page, above the table rows.

Figure B.11 – Repeating header rows

B.7 Styles in the Bibliography

For an unnumbered bibliography, use the Paragraph style (Alt + A) for the entries; style the titles with Emphasis (Alt + I).

For a numbered bibliography (see Figure B.12), use the BIBLIOGRAPHY-numbered style for the entries; style the titles with Emphasis. The references shall be listed in the order that they appear in the text.
B.8 Heading styles in amendments

Headings in amendments tend not to have sequential numbering; therefore, do not use the Heading and Annex heading styles. Use AMD-Heading1 instead of Heading 1 and Annex-heading1; use AMD-Heading2 for all other levels. Insert the heading number manually followed by a tab (see Figure B.13). You may also use a long space (Ctrl + M) instead of the tab; this can lead to clearer results.

Amendment styles are accessed via the Other styles button in the Apply styles group.

B.9 Style shortcuts

Table B.1 lists the keyboard shortcuts for IEC styles for English language versions of Word; many shortcuts do not work in other language versions. You can switch Word to English in File > Options > Language.

Shortcuts can also be viewed by placing the mouse above the buttons in the IEC tools tab.
### Table B.1 – Keyboard shortcuts

<table>
<thead>
<tr>
<th>Style name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paragraph</td>
<td>Alt + A</td>
</tr>
<tr>
<td>Heading 1 / 2 / ...</td>
<td>Alt + [F1] / [F2] / ...</td>
</tr>
<tr>
<td>List number / List number 2 / ...</td>
<td>Alt + 1 / 2 / ...</td>
</tr>
<tr>
<td>List number alt / List number alt 2</td>
<td>Ctrl + 1 / 2</td>
</tr>
<tr>
<td>List Bullet / 2 / 3</td>
<td>Ctrl + [F1] / [F2] / [F3]</td>
</tr>
<tr>
<td>HEADING(nonumber)</td>
<td>Alt + H</td>
</tr>
<tr>
<td>ANNEX-title</td>
<td>Ctrl + Alt + 0</td>
</tr>
<tr>
<td>ANNEX-heading1 / 2 / ...</td>
<td>Ctrl + Alt + 1 / 2 / ...</td>
</tr>
<tr>
<td>Emphasis</td>
<td>Alt + I</td>
</tr>
<tr>
<td>Strong</td>
<td>Alt + B</td>
</tr>
<tr>
<td>Intense Emphasis</td>
<td>Alt + M</td>
</tr>
<tr>
<td>SMALL CAPS</td>
<td>Alt + C</td>
</tr>
<tr>
<td>FIGURE-title</td>
<td>Alt + G</td>
</tr>
<tr>
<td>TABLE-title</td>
<td>Alt + L</td>
</tr>
<tr>
<td>TABLE-centered</td>
<td>Alt + Z</td>
</tr>
<tr>
<td>TABLE-cell</td>
<td>Alt + K</td>
</tr>
<tr>
<td>NOTE</td>
<td>Alt + N</td>
</tr>
<tr>
<td>EXAMPLE</td>
<td>Alt + E</td>
</tr>
<tr>
<td>TERM</td>
<td>Alt + T</td>
</tr>
<tr>
<td>TERM-definition</td>
<td>Alt + D</td>
</tr>
<tr>
<td>TERM-number</td>
<td>Alt + R</td>
</tr>
<tr>
<td>TERM-source</td>
<td>Alt + S</td>
</tr>
<tr>
<td>SUBscript</td>
<td>Alt + U</td>
</tr>
<tr>
<td>SUBscript-small</td>
<td>Alt + Shift + U</td>
</tr>
<tr>
<td>SUPerscript</td>
<td>Alt + O</td>
</tr>
<tr>
<td>SUPerscript-small</td>
<td>Alt + Shift + O</td>
</tr>
<tr>
<td>VARIABLE</td>
<td>Alt + V</td>
</tr>
<tr>
<td>SUBscript-variable</td>
<td>Alt + Ctrl + Shift + U</td>
</tr>
<tr>
<td>SUBscript-small-variable</td>
<td>Alt + Ctrl + Keypad 2</td>
</tr>
<tr>
<td>SUPerscript-variable</td>
<td>Alt + Ctrl + Shift + O</td>
</tr>
<tr>
<td>SUPerscript-small-variable</td>
<td>Alt + Ctrl + Keypad 3</td>
</tr>
</tbody>
</table>